Lỗ hổng nguy hiểm trong eCommerce WordPress Plugin

wp-ecommerce

Các nhà nghiên cứu đã xác định một lỗ hổng khiến rò rỉ thông tin và qua mặt quyền điều khiển trong plugin WP eCommerce – một plugin phổ biến trên WordPress. Plugin WP eCommerce được sử dụng bởi rất nhiều người bán hàng, các trang web thương mại điện từ, download và thành viên trực tuyến. Plugin này được tải về 2.9 triệu lần từ trang chủ của WordPress.

Lỗ hổng bảo mật ảnh hướng đến các ứng dụng có thể khiến tin tặc chiếm được quyền truy cập vào tên, địa chỉ email, thông tin thanh toán và các thông tin khác mà người mua sử dụng qua plugin này. Theo các nhà nghiên cứu, lỗ hổng này cũng có thể dùng để sửa đổi thông tin cá nhân của người dùng. “Tin tặc có thể thực hiện các hành động như một quản trị viên mà không cần xác thực trên trang web mục tiêu. Sử dụng lỗ hổng này, tin tặc có thể gửi yêu cầu đến cơ sở dữ liệu của trang web, lấy toàn bộ thông tin các nhân khách hàng (bao gồm tên, email, địa chỉ…). Tin tặc cũng có thể mua hàng và thay đổi trạng thái giao dịch để chấp nhận thanh toán mà không cần tạo ra một thanh toán thực.”

Lỗ hổng này ảnh hưởng đến WP eCommerce 3.8.14.3 và các phiên bản cũ hơn. Phiên bản 3.8.14.4 được phát hành đã giải quyết vấn đề này. Các nhà nghiên cứu tại Sucuri không đưa ra chi tiết kĩ thuật về lỗ hổng này nhằm ngăn chặn những kẻ tấn công khai thác nó, nhưng các nhà nghiên cứu thông báo rằng lỗ hổng này tương tự như lỗ hổng ảnh hưởng trên MailPoet newsletter plugin.

Lỗ hổng trong WP eCommerce đã được thêm vào WPScan Vulnerability Database. Cho đến nay, cơ sở dữ liệu này chứa thông tin hơn 1300 lỗ hổng ảnh hưởng trên các plugin WordPress và hơn 700 lỗ hổng ảnh hưởng trên chính nền tảng này.

Securityweek

Bình luận

Từ khóa: